CVE-2024-2756 Affecting php-7.2 package, versions <7.2.34+e1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
38.12% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHP72-21716698
  • published26 Oct 2026
  • disclosed29 Apr 2024

Introduced: 29 Apr 2024

CVE-2024-2756  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-7.2 to version 7.2.34+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-7.2 package and not the php-7.2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Due to an incomplete fix to CVE-2022-31629 https://github.com/advisories/GHSA-c43m-486j-j32p , network and same-site attackers can set a standard insecure cookie in the victim's browser which is treated as a __Host- or __Secure- cookie by PHP applications.

CVSS Base Scores

version 3.1