Cross-site Scripting (XSS) Affecting php-laravel-framework package, versions *


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.26% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPLARAVELFRAMEWORK-20335182
  • published30 Sept 2026
  • disclosed28 Sept 2026

Introduced: 28 Sep 2026

NewCVE-2026-102279  (opens in a new tab)
CWE-80  (opens in a new tab)

How to fix?

There is no fixed version for Echo:latest php-laravel-framework.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-laravel-framework package and not the php-laravel-framework package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Laravel is a web application framework. Prior to 12.69.0 and 13.30.0, Laravel exception debug pages with APP_DEBUG=true pass attacker-controlled input to a Tippy.js tooltip configured with allowHTML true, enabling DOM-based cross-site scripting when a user hovers over the tooltip. This issue is fixed in versions 12.69.0 and 13.30.0.