CVE-2026-115557 Affecting python3.13 package, versions <3.13.5-2+e42


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.53% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PYTHON313-21707409
  • published25 Oct 2026
  • disclosed24 Oct 2026

Introduced: 24 Oct 2026

NewCVE-2026-115557  (opens in a new tab)

How to fix?

Upgrade Echo:latest python3.13 to version 3.13.5-2+e42 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3.13 package and not the python3.13 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Python has added a denylist for known compromised certificates to the "ssl" module to ensure user safety even without certificate revocation configured. Known compromised certificates will automatically be rejected regardless of the SSLContext policy configuration.