Uncontrolled Recursion Affecting ruby-crass package, versions *


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.49% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYCRASS-22103808
  • published31 Oct 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-61846  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

There is no fixed version for Echo:latest ruby-crass.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-crass package and not the ruby-crass package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses CSS simple blocks and functions without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises SystemStackError: stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.

CVSS Base Scores

version 3.1