CVE-2026-38969 Affecting ruby-webrick package, versions <1.9.1-1+e1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYWEBRICK-19643823
  • published8 Sept 2026
  • disclosed2 Jul 2026

Introduced: 2 Jul 2026

CVE-2026-38969  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-webrick to version 1.9.1-1+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-webrick package and not the ruby-webrick package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Rejected reason: DO NOT USE THIS CVE RECORD. ConsultIDs: none. Reason: This record was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: none.

CVSS Base Scores

version 3.1