Arbitrary Code Injection Affecting setuptools package, versions <66.1.1-1+deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
1.94% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SETUPTOOLS-19256861
  • published25 Aug 2026
  • disclosed15 Jul 2024

Introduced: 15 Jul 2024

CVE-2024-6345  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Echo:latest setuptools to version 66.1.1-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream setuptools package and not the setuptools package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.

CVSS Base Scores

version 3.1