Improper Input Validation Affecting tesseract package, versions <5.5.0-1+e8


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-TESSERACT-22113828
  • published1 Nov 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-119339  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Echo:latest tesseract to version 5.5.0-1+e8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tesseract package and not the tesseract package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Tesseract is an open source OCR engine. Prior to 5.5.4, WeightMatrix::DeSerialize trusts a mode byte from a traineddata LSTM network and calls WeightMatrix::DeSerializeOld when kDoubleFlag is clear. In default FAST_FLOAT builds, DeSerializeOld invokes ASSERT_HOST instead of returning an error, so loading a crafted model through TessBaseAPI::Init terminates the process and causes denial of service. This issue is fixed in version 5.5.4.

CVSS Base Scores

version 3.1