Incorrect Authorization Affecting tryton-server package, versions <6.0.29-2+deb12u4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-TRYTONSERVER-19637995
  • published6 Sept 2026
  • disclosed30 Nov 2025

Introduced: 30 Nov 2025

CVE-2025-66423  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Echo:latest tryton-server to version 6.0.29-2+deb12u4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tryton-server package and not the tryton-server package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Tryton trytond 6.0 before 7.6.11 does not enforce access rights for the route of the HTML editor. This is fixed in 7.6.11, 7.4.21, 7.0.40, and 6.0.70.