Access Restriction Bypass Affecting github.com/edgexfoundry/edgex-go package, versions >=1.0.1 <2.0.0


0.0
high
  • Attack Complexity

    Low

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMEDGEXFOUNDRYEDGEXGO-1316428

  • published

    11 Jul 2021

  • disclosed

    11 Jul 2021

  • credit

    Bryon Nevis

How to fix?

Upgrade github.com/edgexfoundry/edgex-go to version 2.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass due to improper configuration settings when creating a proxy user while the EdgeX API gateway is configured for OAuth2 authentication

References