Open Redirect Affecting github.com/pomerium/pomerium/authenticate Open this link in a new tab package, versions >=0.10.0 <0.13.4


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPOMERIUMPOMERIUMAUTHENTICATE-1090590

  • published

    4 Apr 2021

  • disclosed

    4 Apr 2021

  • credit

    cure53

How to fix?

Upgrade github.com/pomerium/pomerium/authenticate to version 0.13.4 or higher.

Overview

github.com/pomerium/pomerium/authenticate is a Package authenticate is a pomerium service that handles user authentication and refersh (AuthN).

Affected versions of this package are vulnerable to Open Redirect via unverified API endpoints that may allow modifying parameters. This vulnerability mainly applies to the user sign in/out process.

References