Insecure Permissions Affecting io.jenkins.blueocean:blueocean-parent package, versions [,1.23.3)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-IOJENKINSBLUEOCEAN-727997

  • published

    17 Sep 2020

  • disclosed

    17 Sep 2020

  • credit

    Jinchen Sheng, Ant Security FG Lab.

How to fix?

Upgrade io.jenkins.blueocean:blueocean-parent to version 1.23.3 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Permissions. It does not perform permission checks in several HTTP endpoints implementing connection tests.This allows attackers with Overall/Read permission to connect to an attacker-specified URL.