Privilege Escalation Affecting org.apache.knox:gateway Open this link in a new tab package, versions [,0.12.0)


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEKNOX-31511

  • published

    15 Oct 2017

  • disclosed

    25 May 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.knox:gateway to version 0.12.0 or higher.

Overview

Affected versions of org.apache.knox:gateway are vulnerable to Privilege Escalation. For versions of Apache Knox from 0.2.0 to 0.11.0 - an authenticated user may use a specially crafted URL to impersonate another user while accessing WebHDFS through Apache Knox. This may result in escalated privileges and unauthorized data access. While this activity is audit logged and can be easily associated with the authenticated user, this is still a serious security issue. All users are recommended to upgrade to the Apache Knox 0.12.0 release.

References