Information Exposure The advisory has been revoked - it doesn't affect any version of package org.wildfly.security:wildfly-elytron Open this link in a new tab


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGWILDFLYSECURITY-2847906

  • published

    25 May 2022

  • disclosed

    25 May 2022

  • credit

    Unknown

Amendment

This was deemed not a vulnerability.

Overview

org.wildfly.security:wildfly-elytron is a new WildFly sub-project which is completely replacing the combination of PicketBox and JAAS as the WildFly client and server security mechanism.

Affected versions of this package are vulnerable to Information Exposure via an incorrect JBOSS_LOCAL_USER challenge location when using the elytron configuration may lead to JBOSS_LOCAL_USER access to all users on the machine.