Improper Input Validation Affecting electron package, versions >=14.0.0 <14.1.0 >=13.0.0 <13.5.1 <12.2.1


0.0
medium

Snyk CVSS

    Attack Complexity Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-ELECTRON-1727342
  • published 1 Oct 2021
  • disclosed 1 Oct 2021
  • credit Unknown

How to fix?

Upgrade electron to version 14.1.0, 13.5.1, 12.2.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. Insufficient validation exist in the svg painting code which may access a content-visibility locked element via an svg reference.