Uncaught Exception Affecting apollo-router-2.10 package, versions *


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.52% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-APOLLOROUTER210-20510080
  • published5 Oct 2026
  • disclosed10 Mar 2026

Introduced: 10 Mar 2026

CVE-2026-31812  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

There is no fixed version for Minimos:latest apollo-router-2.10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apollo-router-2.10 package and not the apollo-router-2.10 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Quinn is a pure-Rust, async-compatible implementation of the IETF QUIC transport protocol. Prior to 0.11.14, a remote, unauthenticated attacker can trigger a denial of service in applications using vulnerable quinn versions by sending a crafted QUIC Initial packet containing malformed quic_transport_parameters. In quinn-proto parsing logic, attacker-controlled varints are decoded with unwrap(), so truncated encodings cause Err(UnexpectedEnd) and panic. This is reachable over the network with a single packet and no prior trust or authentication. This vulnerability is fixed in 0.11.14.

CVSS Base Scores

version 3.1