Improper Check or Handling of Exceptional Conditions The advisory has been revoked - it doesn't affect any version of package argocd-fips-3.0-compat  (opens in a new tab)


Threat Intelligence

EPSS
0.59% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-ARGOCDFIPS30COMPAT-13183574
  • published3 Oct 2025
  • disclosed1 Oct 2025

Introduced: 1 Oct 2025

CVE-2025-59531  (opens in a new tab)
CWE-703  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream argocd-fips-3.0-compat package and not the argocd-fips-3.0-compat package as distributed by Minimos.

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Versions 1.2.0 through 1.8.7, 2.0.0-rc1 through 2.14.19, 3.0.0-rc1 through 3.2.0-rc1, 3.1.7 and 3.0.18 are vulnerable to malicious API requests which can crash the API server and cause denial of service to legitimate clients. Without a configured webhook.bitbucketserver.secret, Argo CD's /api/webhook endpoint crashes when receiving a malformed Bitbucket Server payload (non-array repository.links.clone field). A single unauthenticated request triggers CrashLoopBackOff, and targeting all replicas causes complete API outage. This issue is fixed in versions 2.14.20, 3.2.0-rc2, 3.1.8 and 3.0.19.