Out-of-Bounds The advisory has been revoked - it doesn't affect any version of package binutils-dev  (opens in a new tab)


Threat Intelligence

EPSS
0.3% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-BINUTILSDEV-13302736
  • published5 Oct 2025
  • disclosed27 May 2025

Introduced: 27 May 2025

CVE-2025-5244  (opens in a new tab)
CWE-119  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream binutils-dev package and not the binutils-dev package as distributed by Minimos.

A vulnerability was found in GNU Binutils up to 2.44. It has been rated as critical. Affected by this issue is the function elf_gc_sweep of the file bfd/elflink.c of the component ld. The manipulation leads to memory corruption. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 2.45 is able to address this issue. It is recommended to upgrade the affected component.