Privilege Defined With Unsafe Actions The advisory has been revoked - it doesn't affect any version of package cassandra-4.1-oci-entrypoint  (opens in a new tab)


Threat Intelligence

EPSS
1.01% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-CASSANDRA41OCIENTRYPOINT-13332309
  • published6 Oct 2025
  • disclosed4 Feb 2025

Introduced: 4 Feb 2025

CVE-2025-23015  (opens in a new tab)
CWE-267  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cassandra-4.1-oci-entrypoint package and not the cassandra-4.1-oci-entrypoint package as distributed by Minimos.

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.

This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2.

Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.