Incorrect Authorization The advisory has been revoked - it doesn't affect any version of package cassandra-5.0-oci-entrypoint  (opens in a new tab)


Threat Intelligence

EPSS
1.1% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-CASSANDRA50OCIENTRYPOINT-13130611
  • published29 Sept 2025
  • disclosed4 Feb 2025

Introduced: 4 Feb 2025

CVE-2025-24860  (opens in a new tab)
CWE-863  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cassandra-5.0-oci-entrypoint package and not the cassandra-5.0-oci-entrypoint package as distributed by Minimos.

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.

Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.

This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.

Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.