CVE-2026-19015 Affecting consul-fips-2-oci-entrypoint-compat package, versions <2.0.3-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.4% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-CONSULFIPS2OCIENTRYPOINTCOMPAT-18744462
  • published13 Aug 2026
  • disclosed7 Aug 2026

Introduced: 7 Aug 2026

CVE-2026-19015  (opens in a new tab)

How to fix?

Upgrade Minimos:latest consul-fips-2-oci-entrypoint-compat to version 2.0.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream consul-fips-2-oci-entrypoint-compat package and not the consul-fips-2-oci-entrypoint-compat package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Consul Community Edition and Consul Enterprise 1.2.0 through 2.0.2 are vulnerable to an uncontrolled resource consumption issue in the Connect CA roots endpoint that may allow a remote caller to grow the agent's Connect CA roots cache without bound, defeating the operator's cache-disable configuration. This vulnerability, CVE-2026-19015, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.