CVE-2025-56200 Affecting ghost-cli package, versions <1.32.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-GHOSTCLI-18955611
  • published19 Aug 2026
  • disclosed30 Sept 2025

Introduced: 30 Sep 2025

CVE-2025-56200  (opens in a new tab)

How to fix?

Upgrade Minimos:latest ghost-cli to version 1.32.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghost-cli package and not the ghost-cli package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.