CVE-2026-55204 Affecting haproxy-3.0 package, versions <3.0.24-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.48% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-HAPROXY30-20702008
  • published10 Oct 2026
  • disclosed18 Jun 2026

Introduced: 18 Jun 2026

CVE-2026-55204  (opens in a new tab)

How to fix?

Upgrade Minimos:latest haproxy-3.0 to version 3.0.24-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy-3.0 package and not the haproxy-3.0 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

HAProxy through 3.4.0, fixed in commit 9a6d1fe, contains a null pointer dereference vulnerability in hpack_dht_insert() within src/hpack-tbl.c that fails to validate the return value of hpack_dht_defrag() when the memory pool is exhausted. An attacker can trigger HPACK dynamic table insertions under memory pressure to dereference a NULL pointer and crash HAProxy worker processes, causing denial of service.

CVSS Base Scores

version 3.1