Cross-site Scripting (XSS) Affecting joomla-5.4 package, versions <5.4.10-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-JOOMLA54-20888364
  • published14 Oct 2026
  • disclosed30 Sept 2025

Introduced: 30 Sep 2025

CVE-2025-54476  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Minimos:latest joomla-5.4 to version 5.4.10-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream joomla-5.4 package and not the joomla-5.4 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Improper handling of input could lead to an XSS vector in the checkAttribute method of the input filter framework class.