Improper Handling of Highly Compressed Data (Data Amplification) The advisory has been revoked - it doesn't affect any version of package kafka-3.8-fips  (opens in a new tab)


Threat Intelligence

EPSS
0.63% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-KAFKA38FIPS-16326302
  • published1 May 2026
  • disclosed4 Sept 2025

Introduced: 4 Sep 2025

CVE-2025-58057  (opens in a new tab)
CWE-409  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kafka-3.8-fips package and not the kafka-3.8-fips package as distributed by Minimos.

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.