Improper Authorization Affecting kafka-4.3-oci-entrypoint package, versions <4.3.1-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.29% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-KAFKA43OCIENTRYPOINT-17446856
  • published25 Jun 2026
  • disclosed2 Jun 2026

Introduced: 2 Jun 2026

CVE-2026-41115  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade Minimos:latest kafka-4.3-oci-entrypoint to version 4.3.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kafka-4.3-oci-entrypoint package and not the kafka-4.3-oci-entrypoint package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

An improper authorization vulnerability has been identified in Apache Kafka.

The implementation of the CONSUMER_GROUP_DESCRIBE (69) API validates the DESCRIBE operation on the GROUP resource instead of the READ operation that documented in the official kafka documentation and the KIP-848. This discrepancy can result in misconfigured Access Control Lists (ACLs) and unintended security postures, like granting READ permission to users who should not be able to join/sync groups, or allowing users without READ permission (but with DESCRIBE permission) to access sensitive group metadata.

The correct permission for CONSUMER_GROUP_DESCRIBE API is DESCRIBE GROUP so the current implementation is correct. However, the kafka documentation as well as the KIP-848 will be updated to reflect the correct permission. We advise the Kafka users to review existing group ACLs to ensure the principle of least privilege.