CVE-2026-4176 Affecting miniperl-5.42 package, versions <5.42.2-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.74% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-MINIPERL542-15922433
  • published7 Apr 2026
  • disclosed29 Mar 2026

Introduced: 29 Mar 2026

CVE-2026-4176  (opens in a new tab)

How to fix?

Upgrade Minimos:latest miniperl-5.42 to version 5.42.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream miniperl-5.42 package and not the miniperl-5.42 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib.

Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.

CVSS Base Scores

version 3.1