CVE-2026-18140 Affecting peerdb-server package, versions <0.36.27-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.78% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-PEERDBSERVER-20416424
  • published4 Oct 2026
  • disclosed30 Jul 2026

Introduced: 30 Jul 2026

CVE-2026-18140  (opens in a new tab)

How to fix?

Upgrade Minimos:latest peerdb-server to version 0.36.27-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream peerdb-server package and not the peerdb-server package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Uncontrolled recursion in the unknown-key skip path of the aws-smithy-json runtime crate before 0.62.7, which the smithy-rs code generator invokes from every generated struct deserializer, might allow remote unauthenticated users to cause a denial of service (process abort via stack exhaustion) via a single small HTTP request containing deeply nested JSON to a smithy-rs generated server.

To remediate this issue, users should upgrade to aws-smithy-json 0.62.7 or later and rebuild.

CVSS Base Scores

version 3.1