Deserialization of Untrusted Data The advisory has been revoked - it doesn't affect any version of package spark-3.5  (opens in a new tab)


Threat Intelligence

EPSS
2.22% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-SPARK35-13734446
  • published29 Oct 2025
  • disclosed29 Sept 2023

Introduced: 29 Sep 2023

CVE-2023-39410  (opens in a new tab)
CWE-502  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spark-3.5 package and not the spark-3.5 package as distributed by Minimos.

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system.

This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.