Out-of-bounds Write The advisory has been revoked - it doesn't affect any version of package spark-3.5-scala-2.12-compat  (opens in a new tab)


Threat Intelligence

EPSS
1.73% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-SPARK35SCALA212COMPAT-14039536
  • published18 Nov 2025
  • disclosed21 Mar 2024

Introduced: 21 Mar 2024

CVE-2024-29133  (opens in a new tab)
CWE-787  (opens in a new tab)

Amendment

The Minimos security team deemed this advisory irrelevant for Minimos:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spark-3.5-scala-2.12-compat package and not the spark-3.5-scala-2.12-compat package as distributed by Minimos.

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1, which fixes the issue.