OS Command Injection Affecting mariadb11.8-embedded package, versions <3:11.8.8-1.el10_2


Severity

Recommended
0.0
high
0
10

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
1.51% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE10-MARIADB118EMBEDDED-18135810
  • published21 Jul 2026
  • disclosed12 Jun 2026

Introduced: 12 Jun 2026

CVE-2026-48165  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Oracle:10 mariadb11.8-embedded to version 3:11.8.8-1.el10_2 or higher.
This issue was patched in ELSA-2026-33412.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb11.8-embedded package and not the mariadb11.8-embedded package as distributed by Oracle. See How to fix? for Oracle:10 relevant fixed versions and status.

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to before 11.8.8, and 12.3.1, a high-privileged MariaDB user could've used wsrep_sst_receive_address or wsrep_sst_donor global system variables to execute shell commands as the uid of the mariadbd process on the galera joiner node. This issue has been patched in versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2.

CVSS Base Scores

version 3.1