CVE-2026-111497 Affecting nodejs-docs package, versions <1:22.23.2-3.0.2.el10_2


Severity

Recommended
high

Based on Oracle Linux security rating.

Threat Intelligence

Social Trends
Exploit Maturity
Attacked
EPSS
87.99% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE10-NODEJSDOCS-21717802
  • published26 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-111497  (opens in a new tab)

How to fix?

Upgrade Oracle:10 nodejs-docs to version 1:22.23.2-3.0.2.el10_2 or higher.
This issue was patched in ELSA-2026-500516.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nodejs-docs package and not the nodejs-docs package as distributed by Oracle. See How to fix? for Oracle:10 relevant fixed versions and status.

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

References

CVSS Base Scores

version 3.1