Stack-based Buffer Overflow Affecting liblouis-doc package, versions <0:2.5.2-11.el7_4


Severity

Recommended
medium

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
1.55% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE7-LIBLOUISDOC-2517670
  • published10 Apr 2022
  • disclosed2 Aug 2019

Introduced: 2 Aug 2019

CVE-2014-8184  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade Oracle:7 liblouis-doc to version 0:2.5.2-11.el7_4 or higher.
This issue was patched in ELSA-2017-3111.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis-doc package and not the liblouis-doc package as distributed by Oracle. See How to fix? for Oracle:7 relevant fixed versions and status.

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

CVSS Base Scores

version 3.1