Out-of-bounds Write Affecting pidgin-perl package, versions <0:2.10.11-5.el7


Severity

Recommended
medium

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
6.18% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE7-PIDGINPERL-2515696
  • published10 Apr 2022
  • disclosed27 Jul 2018

Introduced: 27 Jul 2018

CVE-2017-2640  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Oracle:7 pidgin-perl to version 0:2.10.11-5.el7 or higher.
This issue was patched in ELSA-2017-1854.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pidgin-perl package and not the pidgin-perl package as distributed by Oracle. See How to fix? for Oracle:7 relevant fixed versions and status.

An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.