Directory Traversal Affecting plexus-archiver package, versions <0:2.4.2-5.el7_5


Severity

Recommended
high

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
11.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE7-PLEXUSARCHIVER-2522799
  • published10 Apr 2022
  • disclosed25 Jul 2018

Introduced: 25 Jul 2018

CVE-2018-1002200  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Oracle:7 plexus-archiver to version 0:2.4.2-5.el7_5 or higher.
This issue was patched in ELSA-2018-1836.

NVD Description

Note: Versions mentioned in the description apply only to the upstream plexus-archiver package and not the plexus-archiver package as distributed by Oracle. See How to fix? for Oracle:7 relevant fixed versions and status.

plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.