Resource Exhaustion Affecting brotli package, versions <0:1.0.6-4.el8_10


Severity

Recommended
high

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
0.55% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE8-BROTLI-15253665
  • published10 Feb 2026
  • disclosed31 Oct 2025

Introduced: 31 Oct 2025

CVE-2025-6176  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Oracle:8 brotli to version 0:1.0.6-4.el8_10 or higher.
This issue was patched in ELSA-2026-2389.

NVD Description

Note: Versions mentioned in the description apply only to the upstream brotli package and not the brotli package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

Scrapy versions up to 2.13.2 are vulnerable to a denial of service (DoS) attack due to a flaw in its brotli decompression implementation. The protection mechanism against decompression bombs fails to mitigate the brotli variant, allowing remote servers to crash clients with less than 80GB of available memory. This occurs because brotli can achieve extremely high compression ratios for zero-filled data, leading to excessive memory consumption during decompression.

CVSS Base Scores

version 3.1