Improper Authentication Affecting curl package, versions <0:7.61.1-30.el8_8.2


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    EPSS 0.06% (23rd percentile)
Expand this section
NVD
5.9 medium
Expand this section
SUSE
5.8 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-CURL-5599941
  • published 16 May 2023
  • disclosed 30 Mar 2023

How to fix?

Upgrade Oracle:8 curl to version 0:7.61.1-30.el8_8.2 or higher.
This issue was patched in ELSA-2023-3106.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

An authentication bypass vulnerability exists in libcurl <8.0.0 in the FTP connection reuse feature that can result in wrong credentials being used during subsequent transfers. Previously created connections are kept in a connection pool for reuse if they match the current setup. However, certain FTP settings such as CURLOPT_FTP_ACCOUNT, CURLOPT_FTP_ALTERNATIVE_TO_USER, CURLOPT_FTP_SSL_CCC, and CURLOPT_USE_SSL were not included in the configuration match checks, causing them to match too easily. This could lead to libcurl using the wrong credentials when performing a transfer, potentially allowing unauthorized access to sensitive information.