Use After Free Affecting expat package, versions <0:2.2.5-10.0.1.el8_7.1


medium

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.52% (77th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
8.1 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-EXPAT-3229390
  • published 14 Jan 2023
  • disclosed 24 Oct 2022

How to fix?

Upgrade Oracle:8 expat to version 0:2.2.5-10.0.1.el8_7.1 or higher.
This issue was patched in ELSA-2023-0103.

NVD Description

Note: Versions mentioned in the description apply only to the upstream expat package and not the expat package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

In libexpat through 2.4.9, there is a use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate in out-of-memory situations.