Out-of-bounds Write Affecting glib2 package, versions <0:2.56.4-159.0.1.el8


medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.24% (65th percentile)
Expand this section
NVD
8.8 high
Expand this section
SUSE
8.8 high
Expand this section
Red Hat
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-GLIB2-3120085
  • published 16 Nov 2022
  • disclosed 1 Nov 2022

How to fix?

Upgrade Oracle:8 glib2 to version 0:2.56.4-159.0.1.el8 or higher.
This issue was patched in ELSA-2022-7704.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glib2 package and not the glib2 package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A memory corruption issue was addressed with improved state management. This issue is fixed in tvOS 15.5, iOS 15.5 and iPadOS 15.5, watchOS 8.6, macOS Monterey 12.4, Safari 15.5. Processing maliciously crafted web content may lead to arbitrary code execution.