CVE-2022-35252 Affecting libcurl package, versions <0:7.61.1-30.el8


0.0
low

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    EPSS 0.14% (49th percentile)
Expand this section
NVD
3.7 low
Expand this section
SUSE
3.7 low
Expand this section
Red Hat
3.1 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-LIBCURL-5600693
  • published 16 May 2023
  • disclosed 23 Sep 2022

How to fix?

Upgrade Oracle:8 libcurl to version 0:7.61.1-30.el8 or higher.
This issue was patched in ELSA-2023-2963.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcurl package and not the libcurl package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

When curl is used to retrieve and parse cookies from a HTTP(S) server, itaccepts cookies using control codes that when later are sent back to a HTTPserver might make the server return 400 responses. Effectively allowing a"sister site" to deny service to all siblings.