Use After Free Affecting libcurl package, versions <0:7.61.1-30.el8


low

Snyk CVSS

    Attack Complexity High
    Availability High

    Threat Intelligence

    EPSS 0.07% (30th percentile)
Expand this section
NVD
5.9 medium
Expand this section
SUSE
5.6 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-LIBCURL-5600699
  • published 16 May 2023
  • disclosed 9 Feb 2023

How to fix?

Upgrade Oracle:8 libcurl to version 0:7.61.1-30.el8 or higher.
This issue was patched in ELSA-2023-2963.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcurl package and not the libcurl package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A use after free vulnerability exists in curl <7.87.0. Curl can be asked to tunnel virtually all protocols it supports through an HTTP proxy. HTTP proxies can (and often do) deny such tunnel operations. When getting denied to tunnel the specific protocols SMB or TELNET, curl would use a heap-allocated struct after it had been freed, in its transfer shutdown code path.