Improper Authentication Affecting libcurl package, versions <0:7.61.1-30.el8_8.3



    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    EPSS 0.18% (55th percentile)
Expand this section
5.9 medium
Expand this section
5.8 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-LIBCURL-5838138
  • published 11 Aug 2023
  • disclosed 30 Mar 2023

How to fix?

Upgrade Oracle:8 libcurl to version 0:7.61.1-30.el8_8.3 or higher.
This issue was patched in ELSA-2023-4523.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcurl package and not the libcurl package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

An authentication bypass vulnerability exists libcurl <8.0.0 in the connection reuse feature which can reuse previously established connections with incorrect user permissions due to a failure to check for changes in the CURLOPT_GSSAPI_DELEGATION option. This vulnerability affects krb5/kerberos/negotiate/GSSAPI transfers and could potentially result in unauthorized access to sensitive information. The safest option is to not reuse connections if the CURLOPT_GSSAPI_DELEGATION option has been changed.