Improper Authentication Affecting libssh package, versions <0:0.9.6-10.el8_8


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.14% (49th percentile)
Expand this section
NVD
6.5 medium
Expand this section
SUSE
4.8 medium
Expand this section
Red Hat
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-LIBSSH-5747738
  • published 30 Jun 2023
  • disclosed 26 May 2023

How to fix?

Upgrade Oracle:8 libssh to version 0:0.9.6-10.el8_8 or higher.
This issue was patched in ELSA-2023-3839.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh package and not the libssh package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A vulnerability was found in libssh, where the authentication check of the connecting client can be bypassed in thepki_verify_data_signature function in memory allocation problems. This issue may happen if there is insufficient memory or the memory usage is limited. The problem is caused by the return value rc, which is initialized to SSH_ERROR and later rewritten to save the return value of the function call pki_key_check_hash_compatible. The value of the variable is not changed between this point and the cryptographic verification. Therefore any error between them calls goto error returning SSH_OK.