SQL Injection Affecting mariadb-pam package, versions <3:10.5.16-2.module+el8.6.0+20717+9b4a4c6e


medium
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-ORACLE8-MARIADBPAM-2970041

  • published

    4 Aug 2022

  • disclosed

    12 Apr 2022

How to fix?

Upgrade Oracle:8 mariadb-pam to version 3:10.5.16-2.module+el8.6.0+20717+9b4a4c6e or higher.
This issue was patched in ELSA-2022-5826.

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-pam package. See How to fix? for Oracle:8 relevant versions.

An issue in the component Arg_comparator::compare_real_fixed of MariaDB Server v10.6.2 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.