Out-of-bounds Write Affecting ncurses-base package, versions <0:6.1-9.20180224.el8_8.1


medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.04% (6th percentile)
Expand this section
NVD
7.8 high
Expand this section
SUSE
6.5 medium
Expand this section
Red Hat
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-NCURSESBASE-5912104
  • published 21 Sep 2023
  • disclosed 14 Apr 2023

How to fix?

Upgrade Oracle:8 ncurses-base to version 0:6.1-9.20180224.el8_8.1 or higher.
This issue was patched in ELSA-2023-5249.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ncurses-base package and not the ncurses-base package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

ncurses before 6.4 20230408, when used by a setuid application, allows local users to trigger security-relevant memory corruption via malformed data in a terminfo database file that is found in $HOME/.terminfo or reached via the TERMINFO or TERM environment variable.