Use of a Broken or Risky Cryptographic Algorithm Affecting openssl-libs package, versions <1:1.1.1c-2.el8


low

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    EPSS 0.34% (72nd percentile)
Expand this section
NVD
5.9 medium
Expand this section
SUSE
5.9 medium
Expand this section
Red Hat
5.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-OPENSSLLIBS-2542148
  • published 10 Apr 2022
  • disclosed 30 Oct 2018

How to fix?

Upgrade Oracle:8 openssl-libs to version 1:1.1.1c-2.el8 or higher.
This issue was patched in ELSA-2019-3700.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-libs package and not the openssl-libs package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

The OpenSSL DSA signature algorithm has been shown to be vulnerable to a timing side channel attack. An attacker could use variations in the signing algorithm to recover the private key. Fixed in OpenSSL 1.1.1a (Affected 1.1.1). Fixed in OpenSSL 1.1.0j (Affected 1.1.0-1.1.0i). Fixed in OpenSSL 1.0.2q (Affected 1.0.2-1.0.2p).

References