Use After Free Affecting pacemaker-libs package, versions <0:2.0.1-4.el8_0.3


Severity

Recommended
0.0
high
0
10

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
1.9% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE8-PACEMAKERLIBS-2532877
  • published10 Apr 2022
  • disclosed18 Apr 2019

Introduced: 18 Apr 2019

CVE-2019-3885  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Oracle:8 pacemaker-libs to version 0:2.0.1-4.el8_0.3 or higher.
This issue was patched in ELSA-2019-1279.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker-libs package and not the pacemaker-libs package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A use-after-free flaw was found in pacemaker up to and including version 2.0.1 which could result in certain sensitive information to be leaked via the system logs.