Buffer Overflow Affecting sqlite-libs package, versions <0:3.26.0-18.0.1.el8_8


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.04% (6th percentile)
Expand this section
NVD
5.5 medium
Expand this section
Red Hat
6.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-SQLITELIBS-5749337
  • published 1 Jul 2023
  • disclosed 11 Apr 2023

How to fix?

Upgrade Oracle:8 sqlite-libs to version 0:3.26.0-18.0.1.el8_8 or higher.
This issue was patched in ELSA-2023-3840.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sqlite-libs package and not the sqlite-libs package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

Buffer Overflow vulnerability found in SQLite3 v.3.27.1 and before allows a local attacker to cause a denial of service via a crafted script.