Uncaught Exception Affecting keylime package, versions <0:6.5.1-1.el9_1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Availability High
Expand this section
NVD
5.1 medium
Expand this section
Red Hat
5.1 medium
Expand this section
SUSE
6.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE9-KEYLIME-3147920
  • published 25 Nov 2022
  • disclosed 22 Nov 2022

How to fix?

Upgrade Oracle:9 keylime to version 0:6.5.1-1.el9_1 or higher.
This issue was patched in ELSA-2022-8444.

NVD Description

Note: Versions mentioned in the description apply to the upstream keylime package. See How to fix? for Oracle:9 relevant versions.

A vulnerability was found in keylime. This security issue happens in some circumstances, due to some improperly handled exceptions, there exists the possibility that a rogue agent could create errors on the verifier that stopped attestation attempts for that host leaving it in an attested state but not verifying that anymore.