Improper Access Control Affecting mod_lua package, versions <0:2.4.62-13.0.1.el9_8.9


Severity

Recommended
high

Based on Oracle Linux security rating.

Threat Intelligence

EPSS
0.44% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ORACLE9-MODLUA-21663272
  • published23 Oct 2026
  • disclosed1 Oct 2026

Introduced: 1 Oct 2026

NewCVE-2026-63045  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Oracle:9 mod_lua to version 0:2.4.62-13.0.1.el9_8.9 or higher.
This issue was patched in ELSA-2026-88229.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mod_lua package and not the mod_lua package as distributed by Oracle. See How to fix? for Oracle:9 relevant fixed versions and status.

Improper validation of FTP PASV reply address in mod_proxy_ftp in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows, in forward proxy configurations, an untrusted FTP server to cause the proxy to open a data connection to an arbitrary third-party host via a crafted PASV response.

Users are recommended to upgrade to version 2.4.69, which fixes this issue.

CVSS Base Scores

version 3.1