CVE-2022-45060 Affecting varnish package, versions <0:6.6.2-2.el9_1.1



    Attack Complexity Low
    Integrity High
Expand this section
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE9-VARNISH-3150781
  • published 29 Nov 2022
  • disclosed 9 Nov 2022

How to fix?

Upgrade Oracle:9 varnish to version 0:6.6.2-2.el9_1.1 or higher.
This issue was patched in ELSA-2022-8643.

NVD Description

Note: Versions mentioned in the description apply only to the upstream varnish package and not the varnish package as distributed by Oracle:9. See How to fix? for Oracle:9 relevant fixed versions and status.

An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.